Interesting GNS3 issue - BGP Route Aggregation

Started by LynK, September 13, 2017, 09:19:29 AM

Previous topic - Next topic

LynK

Was messing around in a lab, configuring 2 different ISPs aggregating 0.0.0.0/1 and 128.0.0.0/1 and then also defaults.

128.0.0.0/1 was getting installed no problems. Trying to figure out what the issue is. Testing 1000 different things. Then a light bulb pops up. Let me try to subnet it smaller.

So I try 0.0.0.0/2, 64.0.0.0/2, 128.0.0.0/1. The 0.0.0.0/2 STILL DOESN'T GET INSTALLED. Anyone got any ideas? Running this in GNS3 on 7200's with version 15.2(4)M7.

For those of you interested, here is the config:

interface Loopback0
ip address 10.0.255.2 255.255.255.255
!
interface Loopback20
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 99.0.0.2 255.255.255.0
ip ospf 100 area 0
duplex full
speed 1000
media-type gbic
negotiation auto
!
interface GigabitEthernet1/0
ip address 32.0.0.2 255.255.255.0
negotiation auto
!
router ospf 100
router-id 10.0.255.2
network 10.0.255.2 0.0.0.0 area 0
!
router bgp 99000
bgp log-neighbor-changes
neighbor 10.0.255.1 remote-as 99000
neighbor 10.0.255.1 update-source Loopback0
neighbor 10.0.255.3 remote-as 99000
neighbor 10.0.255.3 update-source Loopback0
neighbor 32.0.0.1 remote-as 32000
neighbor 32.0.0.1 ebgp-multihop 2
!
address-family ipv4
  network 2.2.2.2 mask 255.255.255.255
  network 99.0.0.0 mask 255.255.255.0
  aggregate-address 0.0.0.0 224.0.0.0 summary-only
  aggregate-address 64.0.0.0 192.0.0.0 summary-only
  neighbor 10.0.255.1 activate
  neighbor 10.0.255.1 next-hop-self
  neighbor 10.0.255.1 soft-reconfiguration inbound
  neighbor 10.0.255.3 activate
  neighbor 10.0.255.3 next-hop-self
  neighbor 10.0.255.3 default-originate
  neighbor 10.0.255.3 soft-reconfiguration inbound
  neighbor 32.0.0.1 activate
  neighbor 32.0.0.1 soft-reconfiguration inbound
  neighbor 32.0.0.1 prefix-list CORP_NETWORKS out
  neighbor 32.0.0.1 route-map BGP_BLOCK_TRANSIT out
exit-address-family
!
ip as-path access-list 10 permit ^$
!
ip prefix-list CORP_NETWORKS seq 5 permit 99.0.0.0/24
no cdp log mismatch duplex
!
route-map BGP_BLOCK_TRANSIT permit 10
match as-path 10


Quickly found this, not 100% sure if it applies:

QuoteCSCtx67474
Symptoms: Update message is sent with an empty NLRI when the message consists of 2byte aspath in ASPATH attribute and 4byte value aggregate attribute.

Conditions: This can happen when there is a mix of 2byte and 4byte attributes in the update message and the message is sent from a 2byte peer and there is a 4byte aggregator attribute.

Workaround: Move all the 2byte AS peers to a separate update-group using a non-impacting outbound policy like "advertisement-interval".
Sys Admin: "You have a stuck route"
            Me: "You have an incorrect Default Gateway"

deanwebb

Take a baseball bat and trash all the routers, shout out "IT'S A NETWORK PROBLEM NOW, SUCKERS!" and then peel out of the parking lot in your Ferrari.
"The world could perish if people only worked on things that were easy to handle." -- Vladimir Savchenko
Вопросы есть? Вопросов нет! | BCEB: Belkin Certified Expert Baffler | "Plan B is Plan A with an element of panic." -- John Clarke
Accounting is architecture, remember that!
Air gaps are high-latency Internet connections.