Switchport Access VLAN in IOS XE

Started by Ironman, June 15, 2015, 10:03:41 AM

Previous topic - Next topic

Ironman

Hello everyone. I just noticed something that is odd to me. We got a new 3850 running IOS XE Cat3k

So I did the following under a host port:

switchport access vlan 10
switchport voice vlan 20


Then when I look at the interface config it only shows me the voice vlan specified:

Interface Gi1/0/1
switchport access
switchport voice vlan 20


BUT under the "show vlan" output it does show that the interface is in both VLANs. Is this just something buggy or new in IOS XE?

NetworkGroover

Uhh - that's interesting.  Is there some kind of default port config putting that port in VLAN 10?
Engineer by day, DJ by night, family first always

Ironman

Let me clear it up, I think my question may of been vague.

On normal IOS here is the output following the addition of both a DATA and VOICE VLAN to a port:

interface GigabitEthernet7/48
description Host Port
switchport access vlan 51
switchport mode access
switchport voice vlan 60


Here is the output now on our NEW 3850 running IOS XE:

interface GigabitEthernet1/10
description Host Port
switchport mode access
switchport voice vlan 60


So, after adding a port to both VLANs in IOS it shows both commands under the configuration of the interface. In IOS XE after adding the port to both VLANs the running-config of the port only displays the VOICE VLAN line, not the DATA one as well like it did in IOS.

I believe the port is fine, since it still shows it in both vlans under the SHOW VLAN command.

routerdork

What code are you running? We've noticed some issues with earlier versions of 3 and have moved onto 03.03.04 and now I believe are going to 03.03.05. I just checked one running 03.03.04 and the VLAN is showing under each switchport config.
"The thing about quotes on the internet is that you cannot confirm their validity." -Abraham Lincoln

NetworkGroover

#4
Quote from: Ironman on June 15, 2015, 11:22:15 AM
Let me clear it up, I think my question may of been vague.

On normal IOS here is the output following the addition of both a DATA and VOICE VLAN to a port:

interface GigabitEthernet7/48
description Host Port
switchport access vlan 51
switchport mode access
switchport voice vlan 60


Here is the output now on our NEW 3850 running IOS XE:

interface GigabitEthernet1/10
description Host Port
switchport mode access
switchport voice vlan 60


So, after adding a port to both VLANs in IOS it shows both commands under the configuration of the interface. In IOS XE after adding the port to both VLANs the running-config of the port only displays the VOICE VLAN line, not the DATA one as well like it did in IOS.

I believe the port is fine, since it still shows it in both vlans under the SHOW VLAN command.

I agree - as long as show output is good, you should be good.  Odd that it doesn't show it though - almost as if it's a default or something....  can you do a show run all int g1/10?
Engineer by day, DJ by night, family first always

Ironman

Quote from: routerdork on June 15, 2015, 11:29:28 AM
What code are you running? We've noticed some issues with earlier versions of 3 and have moved onto 03.03.04 and now I believe are going to 03.03.05. I just checked one running 03.03.04 and the VLAN is showing under each switchport config.

Just upgraded to 03.03.05 and still seeing the same thing. Like I said, I don't think its an operational issue, just a glitch from how I am used to seeing things.

Reggle

You'd expect to be able to tell the untagged vlan on an access port with the show command... "used to see things" or not.

icecream-guy

what is the interface configuration if you so 'show run all',  is the access vlan shown there?
:professorcat:

My Moral Fibers have been cut.

Ironman

It does show up under the show run all. I think I figured it out, kind of had a doh! moment. Keep in mind I did not design this network. The data VLAN is VLAN1. . . I know, I know, horrible practice but it was like this far before I came along and I am just adding a new switch to a DC with other switches that are already in place.

If I could talk to the guy who set this up ----> :developers:

So my guess at this point is that is only shows up in the show run all because VLAN1 is the default VLAN. Make sense, right?

LynK

#9
Unfortunately you are in a real life cisco lab simulator. You are not allowed to issue these commands:

"show run"
"show tech"
"show ver"


For your additional benefit we have also disabled telnet, ssh, console, and xmodem. You have 15 minutes to solve this problem, Good luck!
Sys Admin: "You have a stuck route"
            Me: "You have an incorrect Default Gateway"

NetworkGroover

Quote from: Ironman on June 16, 2015, 08:01:42 AM
It does show up under the show run all. I think I figured it out, kind of had a doh! moment. Keep in mind I did not design this network. The data VLAN is VLAN1. . . I know, I know, horrible practice but it was like this far before I came along and I am just adding a new switch to a DC with other switches that are already in place.

If I could talk to the guy who set this up ----> :developers:

So my guess at this point is that is only shows up in the show run all because VLAN1 is the default VLAN. Make sense, right?

Exactly.  Usually in the case of defaults it won't show in running config, so if you're ever not sure you can use that command.
Engineer by day, DJ by night, family first always