Ether channel.

Started by weasleman, May 14, 2017, 02:23:35 PM

Previous topic - Next topic

weasleman

Hi,

I have three switches in this configuration using VTP and i have created a domain Network1. The two access switches are client within this domain.

Switch1 port fa0/23-24 connect to Fa0/21-22 on CSW1

Switch2 port fa0/23-24 connect to fa0/23-24 on CSW1

I have used PagP to aggregrate the links.

All lights are green  Vlans are being passed though from server to client but for some reason. IPV4 does not seem to work. I have attached Packet tracer lab i created.  :( :( :( :(

What am i doing wrong??


Cheers in advance.

icecream-guy

IP does not need to work in a Layer2 domain,


by " IPV4 does not seem to work" what do you mean?

If you create an IP address on vlan 1, no shut, and connect a computer to port  fa0/1  in vlan 1 and give it an IP on the same network, the PC cannot ping the SVI?
:professorcat:

My Moral Fibers have been cut.

SimonV

I installed Wireshark to test this because it wasn't entirely clear what you mean. Unfortunately you didn't post the password so I can't get into the switch sim. I can ping from one host to the other, by the way, so I'm not sure what's not working for you?

C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::20A:F3FF:FEAE:2BC2
   IP Address......................: 10.1.100.1
   Subnet Mask.....................: 255.255.255.0
   Default Gateway.................: 0.0.0.0

C:\>ping 10.1.100.2

Pinging 10.1.100.2 with 32 bytes of data:

Reply from 10.1.100.2: bytes=32 time=1ms TTL=128
Reply from 10.1.100.2: bytes=32 time<1ms TTL=128
Reply from 10.1.100.2: bytes=32 time<1ms TTL=128
Reply from 10.1.100.2: bytes=32 time<1ms TTL=128

Ping statistics for 10.1.100.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

weasleman

Hi smon,

the passwords are a throw back from a long time ago.

Console password Lambgirl1
Secret password Canada1

I am looking at ether channels as Nic teaming. (Maybe wrong in doing this)

MY LOGIC

CSW1
So logic create port channel 1, Create all the rules switcport trunk etc etc
On the Phisical ports Fa0/23-24 Put them into channel-group 1


Now all trunking rules should be coming from the config in port channel 1. But not sure.

Heres the config

interface Port-channel 1
switchport trunk allowed vlan 1,100,105,110
switchport mode trunk
switchport nonegotiate
!
interface Port-channel 2
switchport trunk allowed vlan 1,100,105,110
switchport mode trunk
switchport nonegotiate

interface FastEthernet0/20
duplex full
speed 100
!
interface FastEthernet0/21
switchport trunk allowed vlan 1,100,105,110
switchport mode trunk
switchport nonegotiate
duplex full
speed 100
channel-group 1 mode desirable
!
interface FastEthernet0/22
switchport trunk allowed vlan 1,100,105,110
switchport mode trunk
switchport nonegotiate
duplex full
speed 100
channel-group 1 mode desirable
!

In the lab i have configure all interfaces including the physical switch ports as trunk mode. But not sure if i should have done this.

The switchport Nonegotiate not sure if this should be used? but reading everyone seems to tuen of DTP traffic.

Thanks again for the quick response. The password show allow you to look at my config.


weasleman

It seems to allow me to ping between PC0 and PC1 but still not sure about the config i used. Hi ristau5741 when i assigned IP addresses to the machines on seperate switches was not able to ping. restarted Packet Tracer but still the same. today it seems to work (i hate it when things do that). Cheers for the reply

weasleman

More reading on this can you confirm if correct or not.

Configuration

CSW1

interface Port-channel 1
switchport mode trunk

Now we get to the interfaces

int range FA0/23-24
Switchport Mode trunk
Switchport nonegotiate (this turns of DTP (dynamic trunking protocol) not need at you are specifying the the negotiation)
Channel-group 1 mode desirable
Do wr

SW1

interface Port-channel 1
switchport mode trunk

Now we get to the interfaces

int range FA0/23-24
Switchport Mode trunk
Switchport nonegotiate (this turns of DTP (dynamic trunking protocol) not need at you are specifying the the negotiation)
Channel-group 1 mode auto
Do wr

I am guessing this correct config? Now my other question is......I want to allow the trunk to only pass the vlans specified.

Switch trunk allowed vlan 100,105,110 (where is this put in the config on the virtual Port-channel or the physical ports? or both?)

I know i am posting way to much but i dont like sitting back and people feeding me the answers without going away and trying to figure it out first. But i am learning so thank you.



weasleman

Anyone? Just want to know were i would restrict the vlans using the the following command.

Switchport trunk allowed Vlan X

Is this placed in the port-channel 1 section or the physical interface Fa0/23

Should be an easy onw to answer


cheers 

RoDDy

#7
Quote from: weasleman on May 17, 2017, 08:52:53 AM
Anyone? Just want to know were i would restrict the vlans using the the following command.

Switchport trunk allowed Vlan X

Is this placed in the port-channel 1 section or the physical interface Fa0/23

Should be an easy onw to answer


cheers

Technically it goes on both but u can add it on the port-channel and the switch should automatically copy the config to the physical interfaces.

weasleman


SimonV

On the physical interfaces, you should only configure physical properties and configure them as child interfaces

For example, to add port 1 and 2 to an LACP Etherchannel:

interface range GigabitEthernet 1/0/1 - 2
speed 1000
duplex full
channel-group 1 mode active


Then apply all of the switchport commands directly to the Portchannel interface

interface Po1
description Po1 - Uplink to xxxx
switchport mode trunk
switchport nonegotiate
switchport trunk native vlan 666
switchport trunk allowed vlan 1,2,3
load-interval 30


The child interfaces will automatically inherit this configuration.

If you add commands on the child interfaces directly, they could move into suspended state because of the config mismatch.

weasleman

I thought as much i have a Udemy course that i am using in conjunction with a CCNA book.

The Udemy course the basically does this

Interface port-channel 1
Switchport mode trunk

Interface range fa0/23-24
Speed 100
Duplex full
switchport mode trunk (Which is why i queried this)
Switchport nonegotiable
channel-group mode active

Thanks again for clarifying my brain doesn't process things unless i understand why I am doing something and it didn't make sense putting the config in two separate places.


icecream-guy

If you mod 1 member interface of the port-channel, the port-channel members interface configurations will no longer match and cause the port channel to go either inconsistent or go down.  (I forget exactly which, but neither is passing traffic)

:professorcat:

My Moral Fibers have been cut.

weasleman

VTP traffic. I am guess that when i create a trunk and if the native vlan does not have access to the trunk VTP packets would not be pased as this is untagged traffic. Never mind think i just answered my own question.

NetworkGroover

Not sure if this was a homework question as I didn't read it thoroughly.  All I have to say is - don't use VTP. Get used to not using it.
Engineer by day, DJ by night, family first always

wintermute000

there's nothing wrong with VTPv3. It fixes everything wrong with v2 and is sane. But people are so burned by old school horror stories they often still refuse to deploy it.

Only the primary server can change the vlan database, and you need to manually use a force command to take over the primary role, so basically that's all the issues of v2 fixed.