Connect Cisco Router to ISP Home Router and access internet

Started by mrana, May 08, 2020, 10:42:53 PM

Previous topic - Next topic

mrana

Hi Guys,

I have a Cisco 2851 Router and a Cisco 3560 Layer 3 switch. I want to make a Cisco networking Lab by connecting my Cisco router to my ISP home router with out affecting the main WiFi internet.

I'd be wondered if any one can help me out how to configure Cisco Router with Putty to connect ISP home router and accessing internet.

My Cisco 2851 Router has two GigabitEthernet port gigabitEthernet 0/0 and gigabitEthernet 0/1

I'd really appreciate your help.

Thanks

ITsupportPeople

Hi mrana,

The following youtube video will demonstrate step by step process how to connect Cisco router ans switch to ISP home router and how to configure Cisco router with console cable and Putty ....


https://youtu.be/rRgdlhSbczU


PuTTY command line for Router Configuration:

Where hostname of the Router is "Router"
Entering to Privileged mode:
Router>enable
Check IP Interface:
#show ip interface brief
Entering to Global Configuration mode:
Router#configure terminal
Entering GE0/0 Interface:
Router(config)#interface gigabitEthernet 0/0
Making Interface up:
Router(config-if)#no shutdown
Assigning IP address from DHCP:
Router(config)# ip address dhcp
Ping to Google DNS server:
Router#ping 8.8.8.8
Entering GE0/1 Interface:
Router(config)#interface gigabitEthernet 0/1
Assigning IP address :
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Making Interface up:
Router(config-if)#no shutdown
Creating DHCP pool:
First go to global configuration mode then
Router(config)#ip dhcp pool mainuser
Router(dhcp-config)#network 192.168.2.0 /24
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Static Routing for default Gateway
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
Configuring NAT Outside:
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Configuring NAT inside:
Router(config)#interface gigabitEthernet 0/1
Router(config-if)#ip nat inside
Router(config-if)#exit
Creating Access list:
Router(config)#ip access-list standard 1
Router(config-std-nacl)#permit any
Router(config-std-nacl)#exit
Overloading IP NAT inside source to the interface gigabitEthernet 0/0:
Router(config)#ip nat inside source list 1 interface gigabitEthernet 0/0 overload
Router(config-if)#exit

deanwebb

Thanks for sharing. I enjoyed the how-to. I would recommend using a console to USB adapter that has the serial connection internalized on the connector. There are several available on the market, and I love not having to keep track of two separate cables.
Take a baseball bat and trash all the routers, shout out "IT'S A NETWORK PROBLEM NOW, SUCKERS!" and then peel out of the parking lot in your Ferrari.
"The world could perish if people only worked on things that were easy to handle." -- Vladimir Savchenko
Вопросы есть? Вопросов нет! | BCEB: Belkin Certified Expert Baffler | "Plan B is Plan A with an element of panic." -- John Clarke
Accounting is architecture, remember that!
Air gaps are high-latency Internet connections.